Обработка-редактор HTML

Публикация № 1075477

Управление - Не имеет значения

33
Редактор HTML для управляемого интерфейса 8.3.

Переработка / компиляция публикаций:
infostart.ru/public/412695
infostart.ru/public/75313

Отличия

  • Все упаковано в одну обработку (формы, картинки, модули)
  • Добавлена возможность вставки изображений (встраиваются как data:image, base64)
  • Исправлены некоторые недочеты

Использование

  • Встроить обработку-редактор HTML в конфигурацию (или расширение).
  • В нужной форме добавить код:
    &НаКлиенте
    Процедура ПолеHTMLДокументаПриНажатии(Элемент, ДанныеСобытия, СтандартнаяОбработка)
    	ПараметрыФормы = Новый Структура;
    	ПараметрыФормы.Вставить("ТекстHTML", Объект.Реквизит1);
    	
    	ОписаниеОповещения = Новый ОписаниеОповещения("ПослеИзмененияТекстаHTML", ЭтотОбъект, Элемент);
    	
    	ОткрытьФорму("Обработка.РедакторHTML.Форма", ПараметрыФормы, ЭтаФорма, ЭтаФорма, , , ОписаниеОповещения, РежимОткрытияОкнаФормы.БлокироватьОкноВладельца);
    	
    КонецПроцедуры
    
    &НаКлиенте
    Процедура ПослеИзмененияТекстаHTML(ДанныеВыбора, Элемент) Экспорт
    	Если ДанныеВыбора = Неопределено тогда
    		Возврат;
    	КонецЕсли;
    	Объект.Реквизит1 = ДанныеВыбора;
    	Элемент.Документ.Body.innerHTML = Объект.Реквизит1;
    	Модифицированность = Истина;
    КонецПроцедуры
    
    &НаКлиенте
    Процедура ПолеHTMLДокументаДокументСформирован(Элемент)
    	Элемент.Документ.Body.innerHTML = Объект.Реквизит1;
    КонецПроцедуры
  • Заменить в коде
    Объект.Реквизит1
    на имя реквизита, В котором хранятся данные

 

Тестировалось на 1С:Предприятие 8.3 (8.3.14.1630).

Changelog

13.06.2009 Исправлена работа кнопок работы с буфером обмена

33

Скачать файлы

Наименование Файл Версия Размер
Обработка-редактор HTML (с примером использования):
.cf 37,96Kb
10.06.19
24
.cf 37,96Kb 24 Скачать

См. также

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. recon 34 11.06.19 11:19 Сейчас в теме
А работу в веб клиенте в браузерах Firefox или chrome не тестировали ?
ValeriVP; +1 Ответить
2. ValeriVP 1014 11.06.19 11:39 Сейчас в теме
(1) Спасибо за замечание
проверил, исправил, проверил - работает в Chrome
3. recon 34 11.06.19 17:10 Сейчас в теме
Протестировал на 8.3.14, тоже все ок.
Интересная ситуация - в 8.3.14 1с всегда использует новый редактор HTML вне зависимости от установленного режима совместимости. И эта обработка там отработала нормально, хотя раньше работа поля HTML напрямую зависело от того какая версия IE используется у клиента, из за чего приходилось извращаться при обработке событий
4. ring_andrey 12 01.07.19 12:15 Сейчас в теме
Валерий, у вас в публикации указана версия 8.3.13, выложена версия 8.3.14. Не могу открыть вашу конфигурацию?!
5. ValeriVP 1014 01.07.19 12:57 Сейчас в теме
(4) исправил версию в публикации. Но все корректно работает и в 8.3.13, просто формат cf уже новый
6. ring_andrey 12 01.07.19 13:14 Сейчас в теме
(5) В 8.3.13 не работает, требует версию 8.3.14. Вы можете сбросить конфигурацию в этой версии? Если бы я знал, что она более старшей версии, чем есть у меня. Я бы ее не стал загружать!
Оставьте свое сообщение