Шаблон внешней печатной управляемой формы с возможностью передачи параметров из клиентской формы в стандартную общую форму печати документов

Публикация № 1043378

Разработка - Печать - Универсальные печатные формы

Управляемы формы внешняя печатная форма параметры печати ОткрытиеФормы печать бирок ПечатьДокументов передача параметров клиента сервер УФ ERP клиент

Шаблон внешней печатной управляемой формы с возможностью передачи параметров из клиентской формы в стандартную общую форму печати документов (проверено на 1С:ERP Управление предприятием 2 (2.4.6.230)).

В процессе написания внешней печатной формы для 1С:ERP Управление предприятием 2 (2.4.6.230), которая, в соответствии с параметрами введенными пользователем в форму, вызываемую при нажатии на соответствующий пункт подменю печати , выводит нужное количество бирок на печать, мною было потрачено много времени на то, чтобы табличный документ, созданный в модуле внешней печатной формы, затем открывался при помощи общей формы печати документов.

Проблема, как мы понимаем, заключается в том, что сначала: нам нужно вызвать на клиенте внешнюю печатную форму, после того как пользователь введет параметры передать их в общую форму печати документов, которая, в свою очередь, должна вызвать процедуру модуля внешней печатной формы - передав в неё нужные параметры, которые пользователь ввел при вызове формы внешней печатной форме на клиенте. Последовательность действий определена и понятна, но тут нужно учитывать креатив создателей общей формы печати документов, единственная переменная, которая может быть передана по всем интересующим звеньям – это массив объектов печати. Сначала я решил не возиться с передачей при помощи массива, а передать параметры через хранилище настроек, но доступ к хранилищам оказался очень ограничен по ролям пользователей, поэтому пришлось вернуться к массиву.

Итак, описание процедур и функций внешней печатной формы:

  1. В модуле обработки создаем обязательные процедуры необходимые для регистрации обработки в базе:
# Область ОбщиеСведения



Функция СведенияОВнешнейОбработке() Экспорт

                ПараметрыРегистрации = Новый Структура;

                МассивНазначений = Новый Массив;

                МассивНазначений.Добавить("Документ.РеализацияТоваровУслуг"); //Указываем документ к которому делаем внешнюю печ. форму

                Попытка

                                //Вид = ДополнительныеОтчетыИОбработкиКлиентСервер.ВидОбработкиДополнительныйОтчет();

                                Вид = ДополнительныеОтчетыИОбработкиКлиентСервер.ВидОбработкиПечатнаяФорма();

                                //Вид = ДополнительныеОтчетыИОбработкиКлиентСервер.ВидОбработкиДополнительнаяОбработка();

                                //Вид = ДополнительныеОтчетыИОбработкиКлиентСервер.ВидОбработкиЗаполнениеОбъекта();

                Исключение

                                //Вид = "ДополнительныйОтчет";

                                Вид = "ПечатнаяФорма";

                                //Вид = "ДополнительнаяОбработка";

                                //Вид = "ЗаполнениеОбъекта";

                КонецПопытки;              

                ПараметрыРегистрации.Вставить("Вид", Вид); //может быть - ПечатнаяФорма, ЗаполнениеОбъекта, ДополнительныйОтчет, СозданиеСвязанныхОбъектов...

                ПараметрыРегистрации.Вставить("Назначение", МассивНазначений);

                ПараметрыРегистрации.Вставить("Наименование", "Шаблон - открытие формы"); //имя под которым обработка будет зарегестрирована в справочнике внешних обработок

                ПараметрыРегистрации.Вставить("БезопасныйРежим", ЛОЖЬ);

                ПараметрыРегистрации.Вставить("Версия", "1.0");

                ПараметрыРегистрации.Вставить("Информация", "Внешняя печатная форма");

                ТаблицаКоманд = ПолучитьТаблицуКоманд();

                //ОткрытиеФормы – Открывает форму обработки.

                //ВызовКлиентскогоМетода – будет вызвана клиентская процедура из модуля формы обработки.

                //ВызовСерверногоМетода  - будет вызвана серверная процедура из модуля обработки.

                //СценарийВБезопасномРежиме – тоже будет вызвана серверная процедура из модуля обработки в безопасном режиме.

                Попытка

                                //Тип = ДополнительныеОтчетыИОбработкиКлиентСервер.ТипКомандыВызовСерверногоМетода();

                                //Тип = ДополнительныеОтчетыИОбработкиКлиентСервер.ТипКомандыВызовКлиентскогоМетода();

                                Тип = ДополнительныеОтчетыИОбработкиКлиентСервер.ТипКомандыОткрытиеФормы();

                Исключение

                                //Тип = "ВызовСерверногоМетода";

                                //Тип = "ВызовКлиентскогоМетода";

                                Тип = "ОткрытиеФормы";

                КонецПопытки;              

                ДобавитьКоманду(ТаблицаКоманд, "Шаблон - открытие формы", "ШаблонОткрытиеФормы", Тип, Истина);

                ПараметрыРегистрации.Вставить("Команды", ТаблицаКоманд);

                Возврат ПараметрыРегистрации;         

КонецФункции // СведенияОВнешнейОбработке()



Функция ПолучитьТаблицуКоманд()

                Команды = Новый ТаблицаЗначений;

                Команды.Колонки.Добавить("Представление", Новый ОписаниеТипов("Строка"));//как будет выглядеть описание печ.формы для пользователя

                Команды.Колонки.Добавить("Идентификатор", Новый ОписаниеТипов("Строка")); //имя макета печ.формы

                Команды.Колонки.Добавить("Использование", Новый ОписаниеТипов("Строка")); //ВызовСерверногоМетода

                Команды.Колонки.Добавить("ПоказыватьОповещение", Новый ОписаниеТипов("Булево"));

                Команды.Колонки.Добавить("Модификатор", Новый ОписаниеТипов("Строка"));

                Возврат Команды;

КонецФункции



Процедура ДобавитьКоманду(ТаблицаКоманд, Представление, Идентификатор, Использование, ПоказыватьОповещение = Ложь, Модификатор = "")

                НоваяКоманда = ТаблицаКоманд.Добавить();

                НоваяКоманда.Представление = Представление;

                НоваяКоманда.Идентификатор = Идентификатор;

                НоваяКоманда.Использование = Использование;

                НоваяКоманда.ПоказыватьОповещение = ПоказыватьОповещение;

                НоваяКоманда.Модификатор = Модификатор;

КонецПроцедуры



# КонецОбласти

 

  1. Создаем реквизит внешней печатной формы «СтруктураПараметровПечати» с типом «Произвольный». Я использовал его в процессе отладки печати для передачи параметров формы на клиенте в серверные процедуры модуля обработки. Реквизит не обязательный. Создаем форму для отображения пользователю, данная форма позволит пользователю ввести нужные параметры. В модуле формы создаем обязательные процедуры необходимые для получения объектов печати при вызове обработки, когда она будет подключена к базе.
&НаКлиенте

Процедура Печать(ИдентификаторКоманды, ОбъектыНазначения) Экспорт

                СтруктураПараметровПечати = Объект.СтруктураПараметровПечати;

                Если СтруктураПараметровПечати = Неопределено ИЛИ НЕ ТипЗнч(СтруктураПараметровПечати) = Тип("Структура") Тогда

                                СтруктураПараметровПечати = Новый Структура;

                КонецЕсли;

                СтруктураПараметровПечати.Вставить("МассивОбъектов", ОбъектыНазначения);

КонецПроцедуры



&НаСервере

Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)

                Если Элементы.Найти("Документ") = Неопределено Тогда

                                Если НЕ Параметры.Свойство("ОбъектыНазначения") Тогда   

                                                Сообщить("Ошибка получения докумнта!");

                                                Отказ = Истина;

                                                Возврат;

                                КонецЕсли;

                КонецЕсли;       

                СтруктураПараметровПечати = Объект.СтруктураПараметровПечати;

                Если СтруктураПараметровПечати = Неопределено ИЛИ НЕ ТипЗнч(СтруктураПараметровПечати) = Тип("Структура") Тогда

                                СтруктураПараметровПечати = Новый Структура;

                КонецЕсли;

                Если Параметры.Свойство("ОбъектыНазначения") Тогда

                                МассивОбъектов = Новый Массив;

                                Для Каждого мЭл Из Параметры.ОбъектыНазначения Цикл

                                                МассивОбъектов.Добавить(мЭл);

                                КонецЦикла;

                                Если НЕ Элементы.Найти("Документ") = Неопределено И НЕ МассивОбъектов.Количество() = 0 Тогда

                                                Документ = МассивОбъектов[0];

                                КонецЕсли;       

                                СтруктураПараметровПечати.Вставить("МассивОбъектов", МассивОбъектов);

                КонецЕсли;

                Объект.СтруктураПараметровПечати = СтруктураПараметровПечати;

                ПечатьБирок = Истина;

КонецПроцедуры

 

ОбъектыНазначения – это массив, в который  платформа помещает объекты печати.

 

  1. В модуле формы: создаем процедуры которые будут отображать табличный документ. При отладке при помощи метода «Показать» табличного документа. Для отображения табличного документа при помощи общей формы вызываем форму печати документов и передаем в неё параметры поместив их в массив «ОбъектыНазначения» элемента структуры «ПараметрыИсточника». Кроме того, необходимо в параметры открытия общей формы поместить элемент с ключом «ИсточникДанных» и в качестве значения поместить ссылку на элемент справочника -  «ДополнительныеОтчетыИОбработки», который будет создан при подключении печатной формы к базе. Это необходимо для того чтобы общая форма при создании на сервере вызвала модуль внешней печатной формы и создала табличный документ.

 

&НаКлиенте

Процедура ПечатьНаКлиенте()

                Если Отладка Тогда

                                мКоллекцияПечатныхФорм = УправлениеПечатьюКлиент.НоваяКоллекцияПечатныхФорм("ШаблонОткрытиеФормы");

                                ТабличныйДокумент = Новый ТабличныйДокумент;

                                КнПечатьНаСервере(мКоллекцияПечатныхФорм);

                                Попытка

                                                ТабличныйДокумент = Объект.СтруктураПараметровПечати.КоллекцияПечатныхФормСтруктура.ТабличныйДокумент;

                                                ТабличныйДокумент.Показать("Шаблон - открытие формы");

                                Исключение

                                КонецПопытки;              

                Иначе

                                ПараметрыОткрытия = Новый Структура;

                                ПолучитьПараметрыОткрытия(ПараметрыОткрытия);

                                Если ПараметрыОткрытия = Неопределено Тогда

                                                Сообщить("Ошибка обработки документа");

                                Иначе

                                                ОткрытьФорму("ОбщаяФорма.ПечатьДокументов", ПараметрыОткрытия);

                                КонецЕсли;       

                                Закрыть();

                КонецЕсли;       

КонецПроцедуры



&НаСервере

Процедура ПолучитьПараметрыОткрытия(ПараметрыОткрытия)

                ИсточникДанных = Справочники.ДополнительныеОтчетыИОбработки.НайтиПоНаименованию("Шаблон - открытие формы");

                Если ИсточникДанных = Неопределено ИЛИ НЕ ТипЗнч(ИсточникДанных) = Тип("СправочникСсылка.ДополнительныеОтчетыИОбработки") Тогда

                                ИсточникДанных = Справочники.ДополнительныеОтчетыИОбработки.ПустаяСсылка();

                КонецЕсли;

                Если Не ЗначениеЗаполнено(ИсточникДанных) Тогда

                                ПараметрыОткрытия = Неопределено;

                                Возврат;

                КонецЕсли;

                ПараметрыОткрытия.Вставить("ИсточникДанных", ИсточникДанных);

                ПараметрыИсточника = Новый Структура;

                ИдентификаторКоманды = "ШаблонОткрытиеФормы";

                ПараметрыПечати = Новый Структура;

                ПараметрыПечати.Вставить("ПечатьБирок", ПечатьБирок);

                ПараметрыПечати.Вставить("КоличествоБирок", КоличествоБирок);

                СтруктураПараметровПечати = Объект.СтруктураПараметровПечати;

                Если СтруктураПараметровПечати = Неопределено ИЛИ НЕ ТипЗнч(СтруктураПараметровПечати) = Тип("Структура") Тогда

                                Если Элементы.Найти("Документ") = Неопределено Тогда

                                                ПараметрыОткрытия = Неопределено;

                                                Возврат;

                                Иначе  

                                                Если ЗначениеЗаполнено(Документ) Тогда

                                                                ТекОбъектыНазначения = Новый Массив;

                                                                ТекОбъектыНазначения.Добавить(Документ);

                                                                ТекОбъектыНазначения.Добавить(ПараметрыПечати);

                                                                ПараметрыИсточника.Вставить("ОбъектыНазначения", ТекОбъектыНазначения);

                                                Иначе  

                                                                ПараметрыОткрытия = Неопределено;

                                                                Возврат;

                                                КонецЕсли;

                                КонецЕсли;

                Иначе

                                Если СтруктураПараметровПечати.Свойство("МассивОбъектов") Тогда

                                                СтруктураПараметровПечати.МассивОбъектов.Добавить(ПараметрыПечати);

                                                ПараметрыИсточника.Вставить("ОбъектыНазначения", СтруктураПараметровПечати.МассивОбъектов);

                                Иначе  

                                                Если ЗначениеЗаполнено(Документ) Тогда

                                                                ТекОбъектыНазначения = Новый Массив;

                                                                ТекОбъектыНазначения.Добавить(Документ);

                                                                ТекОбъектыНазначения.Добавить(ПараметрыПечати);

                                                                ПараметрыИсточника.Вставить("ОбъектыНазначения", ТекОбъектыНазначения);

                                                Иначе  

                                                                ПараметрыОткрытия = Неопределено;

                                                                Возврат;

                                                КонецЕсли;

                                КонецЕсли;

                КонецЕсли;

                ПараметрыИсточника.Вставить("ИдентификаторКоманды", ИдентификаторКоманды);

                ПараметрыОткрытия.Вставить("ПараметрыИсточника", ПараметрыИсточника);

                ПараметрыОткрытия.Вставить("ПараметрКоманды", ПараметрыИсточника.ОбъектыНазначения);

КонецПроцедуры

 

  1. В модуле внешней печатной формы создаем обязательную процедуру: «Печать», которая будет вызвана из процедуры общей формы печать документов – «ПриСозданииНаСервере».

В процедуре печати получаем массив, в котором передавали параметры печати, параметры - помещаем в нужную переменную. Элемент массива, который хранил нужные нам параметры, удаляем. Я прописал удаление перед каждым вызовом общих процедур, для того чтобы убедиться в том, что внутри общих процедур переменная хранящая массив и переданная в процедуру печати модуля внешней печатной формы не перезаполняется из переменной общей формы печати документов.

Процедура Печать(МассивОбъектов = Неопределено, КоллекцияПечатныхФорм = Неопределено,

                ОбъектыПечати = Неопределено, ПараметрыВывода = Неопределено) Экспорт

                ПараметрыПечати = Неопределено;

                н = 0;

                Если НЕ МассивОбъектов = Неопределено И ТипЗнч(МассивОбъектов) = Тип("Массив") Тогда

                                Для Каждого мЭл Из МассивОбъектов Цикл

                                                Если ТипЗнч(мЭл) = Тип("Структура") Тогда

                                                                ПараметрыПечати = Новый Структура;

                                                                ПараметрыПечати.Вставить("ПечатьБирок", мЭл.ПечатьБирок);

                                                                ПараметрыПечати.Вставить("КоличествоБирок", мЭл.КоличествоБирок);

                                        МассивОбъектов.Удалить(н);

                                                КонецЕсли;

                                                н = н + 1;

                                КонецЦикла;

                КонецЕсли;

                Если ПараметрыПечати = Неопределено Тогда

                                СтруктураПараметровПечати = ЭтотОбъект.СтруктураПараметровПечати;

                                ПараметрыПечати = Новый Структура;

                                Если НЕ СтруктураПараметровПечати = Неопределено И ТипЗнч(СтруктураПараметровПечати) = Тип("Структура") Тогда

                                                ПараметрыПечати.Вставить("ПечатьБирок", СтруктураПараметровПечати.ПараметрыПечати.ПечатьБирок);

                                                ПараметрыПечати.Вставить("КоличествоБирок", СтруктураПараметровПечати.ПараметрыПечати.КоличествоБирок);

                                                МассивОбъектов = Новый Массив;

                                                Для Каждого мЭл Из СтруктураПараметровПечати.МассивОбъектов Цикл

                                                                МассивОбъектов.Добавить(мЭл);

                                                КонецЦикла;

                                                КоллекцияПечатныхФорм = Новый ТаблицаЗначений;

                                                Для Каждого ЭлСтруктуры Из СтруктураПараметровПечати.мКоллекцияПечатныхФорм[0] Цикл

                                                                КоллекцияПечатныхФорм.Колонки.Добавить(ЭлСтруктуры.Ключ);

                                                КонецЦикла;

                                                СтрКоллекцияПечатныхФорм = КоллекцияПечатныхФорм.Добавить();

                                                ЗаполнитьЗначенияСвойств(СтрКоллекцияПечатныхФорм, СтруктураПараметровПечати.мКоллекцияПечатныхФорм[0]);

                                                ОбъектыПечати = Новый СписокЗначений;

                                ОбъектыПечати.ЗагрузитьЗначения(СтруктураПараметровПечати.ОбъектыПечати.ВыгрузитьЗначения());

                                                ПараметрыВывода = Новый Структура;

                                                Для Каждого ЭлСтруктуры Из СтруктураПараметровПечати.ПараметрыВывода Цикл

                                                                ПараметрыВывода.Вставить(ЭлСтруктуры.Ключ, ЭлСтруктуры.Значение);

                                                КонецЦикла;

                                КонецЕсли;

                КонецЕсли;

                Если ПараметрыПечати = Неопределено Тогда

                                Сообщить("Не удалось определить параметры печати!");

                                Возврат;

                КонецЕсли;       

                Если УправлениеПечатью.НужноПечататьМакет(КоллекцияПечатныхФорм, "ШаблонОткрытиеФормы") Тогда

                                УправлениеПечатью.ВывестиТабличныйДокументВКоллекцию(

                                                КоллекцияПечатныхФорм,

                                                "ШаблонОткрытиеФормы",

                                                НСтр("ru = 'Шаблон - открытие формы'"),

                                                СформироватьПечатнуюФормуНакладная(МассивОбъектов, ОбъектыПечати, ПараметрыПечати));

                КонецЕсли;

                Если НЕ МассивОбъектов = Неопределено И ТипЗнч(МассивОбъектов) = Тип("Массив") Тогда

                                н = 0;

                                Для Каждого мЭл Из МассивОбъектов Цикл

                                                Если ТипЗнч(мЭл) = Тип("Структура") Тогда

                                        МассивОбъектов.Удалить(н);

                                                КонецЕсли;

                                                н = н + 1;

                                КонецЦикла;

                КонецЕсли;

                Если ПараметрыВывода.Свойство("ПараметрыОтправки") Тогда

                                ФормированиеПечатныхФорм.ЗаполнитьПараметрыОтправки(

                                                ПараметрыВывода.ПараметрыОтправки,

                                                МассивОбъектов,

                                                КоллекцияПечатныхФорм);

                Иначе

                                ОбщегоНазначенияБП.ЗаполнитьДополнительныеПараметрыПечати(МассивОбъектов,

                                                КоллекцияПечатныхФорм,

                                                ОбъектыПечати,

                                                ПараметрыВывода);

                                                КоллекцияПечатныхФормСтруктура = Новый Структура;

                                                Для Каждого Колонка Из КоллекцияПечатныхФорм.Колонки Цикл

                                                                КоллекцияПечатныхФормСтруктура.Вставить(Колонка.Имя, КоллекцияПечатныхФорм[0][Колонка.Имя]);

                                                КонецЦикла;

                                                ЭтотОбъект.СтруктураПараметровПечати = Новый Структура("КоллекцияПечатныхФормСтруктура,ОбъектыПечати,ПараметрыВывода",

                                                КоллекцияПечатныхФормСтруктура, ОбъектыПечати, ПараметрыВывода);

                КонецЕсли;                       

КонецПроцедуры

 

Скачать файлы

Наименование Файл Версия Размер
Шаблон внешней печатной управляемой формы с возможностью передачи параметров из клиентской формы в стандартную общую форму печати документов:
.epf 16,43Kb
14.04.19
5
.epf 16,43Kb 5 Скачать

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. TrinitronOTV 3 15.04.19 12:38 Сейчас в теме
По вашему описанию попробовал создать DGA и возникли такие ошибки:
1. В модуле формы
{ВнешняяОбработка.ШаблонВнешняяПечатнаяФорма.Форма.Форма.Форма(55,3)}: Процедура или функция с указанным именем не определена (КнПечатьНаСервере)
<<?>>КнПечатьНаСервере(мКоллекцияПечатныхФорм); (Проверка: Тонкий клиент)

2. В модуле объекта
{ВнешняяОбработка.ШаблонВнешняяПечатнаяФорма.МодульОбъекта(162,3)}: Переменная не определена (ФормированиеПечатныхФорм)
<<?>>ФормированиеПечатныхФорм.ЗаполнитьПараметрыОтправки(ПараметрыВывода.ПараметрыОтправки, МассивОбъектов, КоллекцияПечатныхФорм); (Проверка: Сервер)
{ВнешняяОбработка.ШаблонВнешняяПечатнаяФорма.МодульОбъекта(146,4)}: Процедура или функция с указанным именем не определена (СформироватьПечатнуюФормуНакладная)
<<?>>СформироватьПечатнуюФормуНакладная(МассивОбъектов, ОбъектыПечати, ПараметрыПечати)); (Проверка: Сервер)
2. user995537 21 15.04.19 14:01 Сейчас в теме
(1) В приложенном файле процедура КнПечатьНаСервере отвечает за вывод табличного документа на экран при открытии формы через меню "Файл" - "Открыть". Выложить шаблон бесплатно не удалось. Если интересует могу бросить шаблон на почту.
Оставьте свое сообщение

См. также

Печать пропусков в Камин 3.0 и Камин 5.0. Обычные формы и управляемые формы

Отчеты и формы Пользователь Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Абонемент ($m) Универсальные печатные формы Пакетная печать

Внешний произвольный отчет для 1с КАМИН:Расчет заработной платы. Версия 3.0. и 5.0 Позволяет печатать пропуска на выбор из папки с табельными номерами в формате jpg  либо из карточки сотрудника в Камине 3.0 и 5.0

1 стартмани

11.02.2020    264    peshitepisma    0       

1C:Предприятие для программистов: Расчетные задачи (зарплата). Онлайн-интенсив с 01 по 17 июня 2020 г. Промо

Данный онлайн-курс предусматривает изучение механизмов платформы “1С:Предприятие”, которые предназначены для автоматизации периодических расчетов, а именно - для расчета зарплаты. Курс предназначен для тех, кто уже имеет определенные навыки конфигурирования и программирования в системе “1С:Предприятие”, а также для опытных пользователей прикладного решения “1С:Зарплата и управление персоналом” и прочих прикладных решений, в которых реализован функционал расчета зарплаты.

4900 рублей

Заполнение шаблона Word docx на сервере, без ComОбъект и внешних компонент, только механизмами самой Платформы 1С, методом XML-инъекции

Отчеты и формы Программист Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Россия Абонемент ($m) Универсальные печатные формы Печатные формы документов

Внешние печатные формы для документа Счет на оплату позволяют сформировать на сервере без использования технологии OLE (Com объекта) и сохранить на печать заполненные docx шаблоны договора поставки и спецификации к договору (УНФ 1.6) (идея универсальна, подойдет для любой конфигурации). Используются только средства самой Платформы 1С:Предприятие 8.3 (8.3.13.1644). Проверено на релизе УНФ 1.6.16.176.

1 стартмани

23.12.2019    3601    16    1sig    3       

Подборка решений для взаимодействия со ФГИС «Меркурий» Промо

С 1 июля 2019 года все компании, участвующие в обороте товаров животного происхождения, должны перейти на электронную ветеринарную сертификацию (ЭВС) через ФГИС «Меркурий». Инфостарт предлагает подборку программ, связанных с этим изменением.

Печать штрихкода для любой конфигурации на платформе 8.3

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Россия Абонемент ($m) Универсальные печатные формы

Платформы младше 8.3.12.1313 использовали ActivX для печати ШтрихКода, сейчас технология изменилась. Эта обработка - замена старого механизма на новый.

2 стартмани

07.11.2019    3975    3    ah7777777    2       

Вывод QR-кода типовыми средствами.

Инструменты и обработки no Внешняя обработка (ert,epf) v8 КА1 УТ10 УПП1 Windows Абонемент ($m) Универсальные печатные формы Сканер штрих-кода Универсальные функции

Вывод QR-кода типовыми средствами. На данный момент очень часто нужно вывести в печатную форму QR-код. Показываю как на примере типового кода из УТ11 это сделать. Можно использовать в любых конфигурациях с обычными формами.

1 стартмани

21.10.2019    4979    9    Емельянов Алексей    25       

Базовый курс по управлению ИТ-проектами. Курс проходит с 26 февраля по 22 апреля 2020 года. Промо

Отличительная черта курса - органичное сочетание трех вещей: 1.Теория проектного управления (PMI®+Agile Alliance+Российские ГОСТ+Методологии от 1С); 2. Опыт внедрения продуктов 1С (опыт франчайзи и успешных компаний + тренды Infostart Event и Agile Days); 3. Разбор реальных проблем и рекомендации экспертов по проектам слушателей. Мы будем фиксироваться на тех инструментах, которые реально оказываются полезными в практике руководителей проектов внедрения. Ведущая курса - Мария Темчина.

от 11000 рублей

Пример внешней печатной формы макета Word (двоичные данные) с клиента

Отчеты и формы Программист Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Абонемент ($m) Универсальные печатные формы

Что делать, если ваша 1С-база клиент-серверная и обычные процедуры получения и заполнения макета Word &НаСервере выдают ошибки? Выход есть! Он представлен в моем примере дополнительной печатной формы с тестовым макетом Word.

1 стартмани

05.09.2019    2046    1    ekaterinaeon    0       

Базовый курс по обмену данными в системе 1С:Предприятие. Онлайн-интенсив с 12 по 28 мая 2020 г. Промо

Данный онлайн-курс предусматривает изучение механизмов платформы “1С:Предприятие”, обеспечивающих обмен данными между различными прикладными 1С-решениями и взаимодействие с другими информационными системами. Курс предназначен для тех, кто уже имеет определенные навыки конфигурирования и программирования в системе “1С:Предприятие”.

5500 рублей

Универсальные печатные формы в управляемой форме

Отчеты и формы Программист Архив с данными v8::УФ 1cv8.cf Казахстан Абонемент ($m) Универсальные печатные формы

Универсальные печатные формы + Возможность редактировать печатную форму в режиме предприятия на лету + Код заполнения в режиме предприятий + Конструктор запросов и конструктор заполнения областей + Хранит и восстанавливает версий макет и кода заполнения + Легко для изучения и работы не для программистов

5 стартмани

01.07.2019    3448    10    t_prog    0       

Печать штрихкода

Отчеты и формы Пользователь Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Абонемент ($m) Универсальные печатные формы

Обработка на управляемых формах. Доступны три варианта печати штрихкода: пользователи, контрагенты и номенклатура.

1 стартмани

28.06.2019    1821    1    v3132    0       

Онлайн-курс "Подготовка к экзамену 1С:Эксперт и 1С:Профессионал по технологическим вопросам" с 7 по 24 апреля 2020 г. Промо

На курсе вы получите практические навыки решения задач производительности 1С, в том числе характерных для высоконагруженных информационных систем (более 1000 пользователей). Подготовка к экзамену – только одна из составляющих курса. 70% слушателей приходят за знаниями, которые позволят расти и зарабатывать, делать сложные задачи на крупных проектах.

16450 рублей

Редактор-конструктор визиток

Инструменты и обработки Пользователь Конфигурация (md, cf) v8 Издательство, полиграфия, упаковка Windows Абонемент ($m) Универсальные печатные формы

Интерактивный редактор-конструктор визиток / персональных карточек на основании макетов.

5 стартмани

16.06.2019    2507    5    eugenevk    6       

Подсистема справок (ЗУП 3.х)

Отчеты и формы Программист Пользователь Внешняя обработка (ert,epf) v8 v8::СПР ЗУП3.x БУ Зарплата Управление персоналом (HRM) Абонемент ($m) Универсальные печатные формы Справки

Подсистема справок внешней печатной формой для 1C: Зарплата и Управление Персоналом, редакция 3.х.

1 стартмани

25.04.2019    5701    19    🅵🅾️🆇    10       

Голосование за доклады на INFOSTART MEETUP Kazan - до 25 февраля. Промо

Выбирайте и голосуйте за самые интересные доклады! Лучшие из лучших попадут в окончательную программу казанского митапа. Оставить свой голос можно до 25 февраля 2020 года.

Универсальная печатная форма "Анализ объекта" + шаблон подключаемой обработки для 1С на управляемых формах

Отчеты и формы Программист Стажер Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Россия Абонемент ($m) Универсальные обработки Универсальные печатные формы

Универсальная печатная форма для всех программ на управляемых формах. Результат печати содержит все реквизиты и табличные части всех документов и справочников (имя + синоним + значение реквизита или поля табличной части), показывает уникальный идентификатор (УИД/GUID) объекта и дату создания (даже справочника) на основании УИД. Отказоустойчивость кода обработки позволяет ей открываться как в типовых, так и в самописных программах (большинство обычных внешние печатных форм этого не могут). Кроме интерактивного открытия есть возможность подключения к конфигурации. После добавления появится команда печати почти во всех документах и справочниках. Автоматически определяет среду подключения и выбирает доступный вариант вывода: общая форма печати или же отображение табличного документа в новой форме. Все реквизиты любого объекта получает запросом, а не перебором строк, что ускоряет выполнение команды.

1 стартмани

05.04.2019    8138    20    Aleksandr55555    4       

Счет на оплату, ТОРГ-12, Счет-фактура, УПД для 1С: ERP (комплект пакета одним файлом)

Отчеты и формы Бухгалтер Архив с данными v8 v8::УФ ERP2 Россия БУ Оптовая торговля Абонемент ($m) Печатные формы документов Универсальные печатные формы

Комплект рабочих внешних печатных форм за 2019 для 1С: ERP (версия 2.4) Управление предприятием 2 для дальнейших разработок. Простата в установке. Добавил и пользуйся. Либо для тестирование. С формой для откладки. В комплект пакета входит: Счет фактура; Торг-12, счет-фактура, упд (Универсальный передаточный документ).

2 стартмани

01.04.2019    2749    13    Kontakt    4       

Подборка программ для взаимодействия с ЕГАИС Промо

ЕГАИС (Единая государственная автоматизированная информационная система) - автоматизированная система, предназначенная для государственного контроля за объёмом производства и оборота этилового спирта, алкогольной и спиртосодержащей продукции. Инфостарт рекомендует подборку проверенных решений для взаимодействия с системой.

Шаблон внешней печатной формы для БСП с универсальной формой тестирования

Отчеты и формы Программист Внешняя обработка (ert,epf) v8 ERP2 ЗКГУ3.0 БП3.0 УТ11 КА2 ЗУП3.x Россия Абонемент ($m) Универсальные печатные формы

Данный шаблон содержит форму тестирования печати для конфигураций, разработанных на базе БСП. Форма универсальная - сама определяет команды печати и поддерживаемые объекты. Не требует доработок. Скопируйте ее в ваши обработки печатных форм и назначьте основной. Далее тестируйте через файл-открыть.

1 стартмани

25.03.2019    2785    9    aves    0       

Макет оформления "Печатные формы" для отчетов на СКД (черно-белый)

Отчеты и формы Программист Документ XML v8 v8::СКД 1cv8.cf Абонемент ($m) Универсальные печатные формы

Готовый макет оформления для отчетов СКД. Макет представляет собой простой черно-белый вариант, с крупным шрифтом в группировках.

1 стартмани

15.03.2019    5144    4    rpgshnik    5       

Открыто голосование за доклады на INFOSTART MEETUP Krasnodar Промо

Выбирайте и голосуйте за самые интересные доклады, лучшие из них попадут в окончательную программу митапа. Голосование продлится до 30 января 2020 года.

QR код: печать. Полностью самодостаточная обработка

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Россия Абонемент ($m) Универсальные печатные формы

Печать QR кода с использованием лишь одной обработки. Подойдет как при разработке своей конфигурации, так и при использовании типовой. Тестировал на 1С: Реестр государственного и муниципального имущества, редакция 3.0 (3.0.2.9).

1 стартмани

12.12.2018    3080    5    user785225    2       

Готовые переносы данных из различных конфигураций 1C Промо

Рекомендуем готовые решения для переноса данных из различных конфигураций 1C. C техподдержкой от разработчиков и гарантией от Инфостарт.

Шаблон внешней печатной формы (УФ) с формой для отладки

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Украина Абонемент ($m) Универсальные печатные формы

Шаблон внешней печатной формы (УФ) с формой для отладки, выводом макета на всех языках конфигурации.

1 стартмани

12.12.2018    4275    3    agressor    11       

Новый раздел на Инфостарте - Electronic Software Distribution Промо

Инфостарт напоминает: на нашем сайте можно купить не только ПО, связанное с 1С. В нашем арсенале – ESD-лицензии на ПО от ведущих вендоров: Microsoft, Kaspersky, ESET, Dr.Web, Аскон и другие.

  • Низкие цены, без скрытых платежей и наценок
  • Оперативная отгрузка
  • Возможность оплаты с личного счета (кешбек, обмен стартмани на рубли и т.п.)
  • Покупки идут в накопления для получения скидочных карт лояльности Silver (5%) и Gold (10%)

Шаблоны печатных форм на лету!

Отчеты и формы Программист Конфигурация (md, cf) v8 Россия Windows Абонемент ($m) Универсальные печатные формы

Справочник шаблонов печатных форм. Платформа 1С:Предприятие 8.3 (8.3.12.1616). Функционал новой платформы не использовался.

1 стартмани

12.11.2018    5393    13    zykov_vitaliy    5       

Универсальный печатный шаблон WORD

Отчеты и формы Программист Расширение (cfe) v8::УФ 1cv8.cf Россия Windows Абонемент ($m) Печатные формы документов Универсальные печатные формы

Было это в УПП 1.3, кадровики достали с печатками (здесь запятой не хватает, здесь ошибка и т.д.). Сделал обработку, научил. К сожалению,  эта обработка была глубоко интегрирована в УПП, поэтому простой перенос не подошёл. Поэтом перенес на УФ в расширение.

1 стартмани

13.08.2018    5776    9    SanyMaga    4       

Программы для исполнения 488-ФЗ: Маркировка товаров Промо

1 января 2019 года вступил в силу ФЗ от 25.12.2018 № 488-ФЗ о единой информационной системе маркировки товаров с использованием контрольных (идентификационных) знаков, который позволяет проследить движение товара от производителя до конечного потребителя. Инфостарт предлагает подборку программ, связанных с применением 488-ФЗ и маркировкой товаров.

Печать непроведённых документов (Расширение)

Отчеты и формы Бухгалтер Расширение (cfe) v8 v8::СПР ЗКГУ3.0 ЗУП3.x БУ Зарплата Абонемент ($m) Универсальные печатные формы Печатные формы документов

Расширение добавляет возможность печатать любой документ, не проверяя его на проведённость.

1 стартмани

12.04.2018    7547    13    the1    3       

INFOSTART MEETUP Kazan. 13 марта 2020 г. Промо

Инфостарт продолжает путешествие по России. Следующая остановка - Казань. Тема мероприятия - управление и технологии автоматизации учета на платформе "1С: Предприятие". Ждем всех: докладчиков и участников! Стоимость участия - 5 500 рублей. Цена действительна до 30.01.2020

5 500

Обработка печатной формы WORD клиент-сервер УФ

Статья Программист Внешняя обработка (ert,epf) v8::УФ 1cv8.cf Абонемент ($m) Универсальные печатные формы

Это моя первая статья на данном портале, но попытаюсь изложить все понятно и подробно. Долгое время у меня заняло создание такой вот внешней обработки. Есть очень много примеров, как сделать подобное на неуправляемых формах (2.0) и очень мало информации касательно управляемых(3.0), по крайней мере я многого найти не смог в доступе. Создание подобное обработки выглядит вполне несложно, если производить все действия на сервере, как это было с 2.0, но в нашем случае необходимо инициализировать открытие документа на клиенте, чему сильно мешает отсутствие возможности передать макет Active Document с сервера на клиент.

2 стартмани

14.03.2018    19959    78    LeoKeyn    41